
LOAD CONTROL PROGRAM  EES-100
OVERVIEW

The load control program allows you to control electronic loads through your PC in four control modes,

• Constant Current - Maintains a constant current through the load independent of the voltage applies across 
it.

• Constant Voltage - A constant voltage is maintained across the load. In this mode, there must be some 
series resistance between a constant voltage source and the electronic load in order for the voltage across 
the load to be varied.

• Constant Resistance - Maintains the load at constant resistance. The ratio of load voltage/load current is 
set to the desired resistance.

• Constant Power - A constant V*I power is maintained. This has a maximum value depending on the series 
resistance in the circuit.

The program can be run in a 'Demo' mode or an 'Online' mode. The Demo mode uses an internal model of a voltage 
source and series resistance and does not connect to any real hardware. The voltage source and series resistance in 
the model can be set by the user. The 'Online' mode connects to the real hardware and needs a program software 
'Key' to operate. The software key can be obtained from the software vendor.

PROGRAM DISPLAY



The main display is broken into 4 sections - Test Control, Load Control, Data Logging, Load Display.

TEST CONTROL
Test Time - Allows you to set a certain test time. At the end of this time the test will stop. If all fields are blank, the 
test will run continuously.
Stop Levels - Allows you to set voltage or current levels where the test will stop. The Enable checkbox must be 
checked for the limit to be active. When the test is stopped, the Load On/Off display will read "Load Off at," 
followed below by the conditions of the load before it was shut off.
Cycle Time (Up and Down) - Sets the number of seconds where the load is 'On (up)' or 'Off (down)'. For the 
numbers shown, the load will start On for 2 seconds, go Off for 4 seconds, then On for 2 seconds, Off for 4 
seconds, etc.
Start/Stop Button - Press this button to start the test after all test variables are set. This button turns into a 'Stop' 
button when the test is started. You can stop the test at any time by pressing the 'Stop' button. The current state of 
the load is maintained after Stop is pressed, and the load is reset by pressing the Reset button.
Reset Button - This button is used to reset the load after the 'Stop' button is pressed.

LOAD CONTROL
Load Type - This selects the model type of the load that is being controlled. Warning - Make sure you select the 
right load type since this changes the current command and measurement scaling.
Max Current - The 'Max Current' display sets a current limit and indicates the maximum current command that will 
be sent to the load. This is set by entering the value in the text box and pressing the 'Set Max' button. This must be 
set to a non-zero value before the load can be controlled. For the Demo mode, this value should be set to the demo 
source voltage / series resistance.
Load Mode - Selects the load control mode.
Command Level - This sets the command level to the control loops. The units of the command depends on which 
control mode is selected (command current, voltage, resistance, or power). This level is set by entering the 
command value in the text box and pressing the 'set level' button. The value can also be incremented or 
decremented by entering a increment value and pressing the '+' or '-' button.

LOAD MEASUREMENT DISPLAYS
Elapsed Time - Shows the elapsed time from the beginning of the test.
Load Off/On - Indicates the state of the load. If the load is stopped by one of the 'Stop Levels' in the Load Control 
section , the Load Off/On display will read "Load Off at," followed by the conditions of the load before it was shut 
off. These conditions are displayed below the Load Off/On display.
Volts - Shows the measured voltage.
Amps - Shows the Commanded current.
Measured Current - This is the value of the Measured current in the load circuit.
Ohms - Shows the computed resistance (V/I).
Watts - Shows the computed power (V*I).
On Time, Off Time - These show the total On time and Off time since the test started.
Amp Hours - This accumulates the measured current value multiplied by time. For each time interval, the value of 
current*time increment is summed together from the start of the test and is converted to amp-hours and displayed.
Estimated Series Resistance - This is a estimated quantity of the series resistance between the voltage source and 
the load and is derived from internal control loop values. This is for indication only and should not be interpreted 
as an accurate value of the actual resistance, although in many cases it is close.
Data Smoothing Checkbox - If this is checked, smoothing is applied to the displayed values and display noise is 
suppressed. The data smoothing time (time constant) can be set through the 'Properties->Control' menu selection.

DATA LOGGING
ASCII CSV File Checkbox - When checked, this selection will write data to the text file entered in the file textbox. 
The data is written as Comma Separated Values (CSV), this is a standard format which can be read by other 
programs such as Excel, Access, FoxPro, etc. The file can also be selected by the 'Browse' button. The full path 
name must be entered, and an error will be displayed if the path to the file does not exist. The following data is 
written to the file.



"Time","Time Hr","Time Min","Time Sec","Amp Hours","milliAmp Hours","Load Type","Control 
Mode","Control Command","Load State","Commanded Current","Measured Current","Measured 
Voltage","Calculated Power","Calculated Resistance","Total On Time","Total Off Time"

Excel Spreadsheet Checkbox - This option must have the Excel program installed on the computer that is running 
the Load Control Program. When this option is selected, the program will open an Excel workbook and insert data 
into a spreadsheet as it is collected. If an Excel Chart is defined in the workbook, the Chart will be automatically 
updated and the latest data displayed. The workbook to be opened can be selected using the 'Browse' button. To 
choose what data is inserted into the spreadsheet, press the 'Excel Setup' button. The following window will be 
displayed.

Using this window, an Excel data column can be set for each load program variable. If the column is blank, the 
variable will not be recorded. Using this form, you can set any variable to any Excel column. You can  also set the 
Excel sheet number where the data will be stored. You can select, using the checkbox, whether or not Excel will be 
displayed while the data is being logged.

Log Interval - This textbox on the Main window allows you to choose the time interval between data logs. A 
blank entry will do data logging every sec, while a value of 10 sec will store values every 10 seconds, for example. 
This value should be set to a reasonable data sample to record the test results you need, while avoiding storing and 
processing large amounts of unnecessary data.

Output Window - The Output Window button will show a list of data collected from the start of the test. An 
example output is shown below. You can use this form to monitor test results as data is being collected. You can 
also Save, Print, or Copy the window contents using the window menu selections. The output window will store a 
maximum of 10,000 data lines.



Graph - The Graph display  is used to monitor and display test results in a graphical form. You can choose one X 
axis variable and up to six Y axis variables (Curves) using the 'Graph->Properties' menu selection. In the Properties 
window, select the X and Y axis variables and their max value. You can also select the number of X and Y graph 
divisions that are displayed on the axes. For a Y axis Curve to be displayed, the 'Show' checkbox must be set. Also 
set the curve color by pressing the 'Set' button. Press the 'Update Graph' to update the graph axes with the property 
values and set the curve properties. The maximum value of the Y axis is set to the largest maximum Y value of all 
the checked curves. During or after a test, the graph can be rescaled by changing the max values and pressing the 
'Update Graph' button.
 The Graph Labels are set by the 'Graph->Label' menu selection. To remove a label from the display, set the label 
value to a blank. All the labels except the 'Graph Title' can be moved on the graph by clicking the upper left corner 
of the label and dragging it to a new position.
The Graph 'File' menu will allow you to Save, Load, or Print a graph. You can also copy a graph display by making 
is the active window and pressing 'Alt, Ptr Scrn'. Graphs are limited to 10,000 points.





MAIN DISPLAY MENUS

File Menu - The 'File' menu allows you to Save and Load test setups. To save a setup, select 'File->Save' and type 
in a setup name into the 'Setup Name' textbox, then press the 'Save Setup' button. The setup will be saved under 
that name. To load a setup, select 'File->Load Setup' and select a setup from the displayed list. A setup may be 
deleted in either the 'Save' or 'Load' dialogs by selecting the setup and pressing the 'Delete' button.

Modes Menu - The two modes that can be selected are the 'Demo' mode and the 'Online' mode. The Demo mode 
uses an internal model of a voltage source and series resistance and does not connect to any real hardware, but all 
the program functions are operational. The voltage source and series resistance in the Demo voltage model can be 
set by the user through the 'Properties->Demo' menu. The 'Online' mode connects to the real hardware and needs a 
program software 'Key' to operate. The software key can be obtained from the software vendor. Before operating in 
the OnLine mode, set the I2C bus speed as described in the Properties, Hardware section below.

Properties Menu - The Properties menu is used to change the properties of the program under various 
categories. The properties windows are shown below.



Properties, General - You can select whether to start the Load Control program in the 'Demo' or 'Online' mode.

Properties, Demo - Allows you to set the Voltage source value and series resistance for the model of the load 
control circuit. The circuit model consists of the voltage source driving the series resistance and the load. While 
running in the demo mode, the max current setting in the main display should be set to Vsource/Series Resistance.



Properties, Hardware - Allows you to set the voltage measurement A/D channel, add a current command bias, 
calibrate the measured current to the current command, and set and measure the I2C bus speed.
The load voltage is normally measured using A/D channel 2. The hardware can be also set up so that the Aux 1 
channel can be used, and the Aux 1 selection allows you to set up the Aux1 gain and voltage range.
The current command bias allows you to add a correction bias to the current command. This would be done by 
commanding a zero current and using an amp meter to read the actual current. Enter the actual current reading into 
the textbox. This value will be subtracted from the current command before it is sent to the hardware.
The current measurement calibration calibrates the measured current to the command current. The command 
current is a more accurate indication of what the actual load current is, and this operation will take out any small 
gain or bias errors in the current measurement. During this calibration routine,  the current command is set to 
multiple points between 0 and the max current (set in the main display), then the measure current is read. Gain and 
offset corrections are computed from these points and applied to the measured values. This calibration should be 
done after any current command biases (Current Command Bias textbox) are entered.  During this calibration, 
current commands are sent to the load up to the Max Current displayed in the Main Program Window. Make sure 
to set this value to an appropriate level since the calibration will occur over this range. Also, the load must be 
turned on and connected to a voltage source.
The I2C Bus speed must be run in the 'OnLine' mode with I2C bus active (powered). The speed can be set by 
entering a desired speed in the textbox and pressing the 'Set I2C Speed' button. The display will flash as the speed 
is set. Do this operation several times until the desired speed is reached. If a 'Max' is displayed, the maximum bus 
speed for the computer you're using has been reached. The bus speed can be measured by pressing the  'Calculate 
I2C Bus Speed' button.



Properties, Control - Using the Control properties, you can set the control loop gain and the data smoothing 
time. You should normally leave the control loop gain at the default value of .5. Setting too high a gain can make 
the control loop unstable, too low a gain can make it sluggish. The Data Smoothing Time sets the time constant of 
the display value filters. The filters are only active if the Data Smoothing checkbox on the Main Display is checked.

Importing the ASCII CSV File Data into Excel

You can import the ASCII CSV data file generated by the Load Control program into Excel for data manipulation, 
reporting, or graph plotting.

To import a file,
- On the Excel menu, select Data->Get External Data->Import Text File.
- Select the text file you generated from the Load Control program.
- A Wizard dialog will come up, choose the 'Delimited' data type option, press 'Next'
- On the second screen, choose the 'Comma' delimiter, press 'Next'
- On the third screen, leave the data format at 'General', click 'Finish'
- The next form asks where you want the data. Select cell A1 if it's not already selected. Press 'OK'
- The data should be imported into the Worksheet. You can delete the columns you don't want and save the 

results.

To generate an Excel Graph,
- On the Excel worksheet, click on a column, such as col B, which is to be used as the X-Axis. This should 

be a real number, such as time in hrs, amp-hrs, time in sec, measured voltage, etc. Then hold down the Ctrl 
key and click on the columns you want on the Y axis, such as commanded current (col J) and measured 
voltage (col L). Click on the Chart Wizard on the tool bar.

- Select 'XY (Scatter)' on the Chart Type, and select the last box in sub-types, 'Scatter with data points 
connected by lines without markers'. Press 'Next'

- The next step should have a graph picture with Series in 'Columns' selected. The Data Range should cover 
the entire column data. Click on the 'Series' tab on the form. A 'Series' is a curve, such as commanded 
current or measured voltage. You can add and remove curves using this display. For each curve, you can 
enter the Name of the curve, the X axis column data range (this should be the same for all curves), and the 
Y axis curve data range. Click 'Next'



- In the next window, you can fill in the Chart options - Titles, Gridlines, and Legend. Press 'Next'
- You can embed the chart in the worksheet or create a new sheet. Click on 'As new sheet', then press 

'Finish'.
- A new Chart will be generated in the workbook. You can change the chart by right-clicking on the chart in 

the Plot Area. Selecting 'Source Data' will allow you to add or delete curves (Series), and the other menu 
selections allow you to modify the other chart characteristics. Click on the chart titles to modify or move 
the text. To change the axis scale, right-click on the scale and select 'Format Axis', then click the 'Scale' 
tab. You can format the 'Chart Area' by right-clicking on the white space (where the titles are placed, not 
in the 'Plot Area').

Importing the ASCII CSV File Data into Access

To import Load Control data into Access, follow these steps,
- In Access, create a new blank database
- Under the 'File' menu, select 'File->Get External Data->Import'
- When the File dialog comes up, show text files by changing 'Files of Type' at the bottom to 'Text Files'. 

Select the ASCII CSV file you want to import.
- The 'Import Text Wizard' will come up with 'Delimited' selected, press 'Next'.
- On the next screen, select 'Comma', and 'First Row Contains Field Names'. Click 'Next'.
- Store the data in a new table, click 'Next'.
- The next screen will allow you to select the fields you want to import. If you don't want to include a field 

in the database, select the field and check the 'Do not import field' box. You can also do this by clicking 
the 'Advanced' button. Click 'Next'.

-  The next screen allows you to choose a key, normally you would 'Let Access add Primary Key'. Click 
'Next'.

- Import to the new Table you created. Uncheck the selection  'I would like a wizard to analyze my table 
after importing the data' if it is checked. Click 'Finish'

-


